Montar un cluster en Linux – Ubuntu

17 Replies

Linux Programación Trucos Tutoriales

Un cluster de ordenadores puede ser bastante complicado de montar y configurar, en esta guía que hemos realizado podrás construirte un cluster en tu casa con varios equipos. Nosotros hemos utilizado el sistema operativo Ubuntu 10.04 aunque también funcionará con versiones anteriores y posteriores, dos equipos Pentium D a 3.2 Ghz y 1GB de RAM cada uno.

El software y librerías que hemos utilizado es Mpich2, que permite la configuración del sistema y ejecución de aplicaciones de memoria distribuida que utilizan computación paralela.

Al final de la instalación y configuración, podrás probar el cluster con varios programas de ejemplo desarrollados en paralelo con las librerías MPI.

Con este pequeño tutorial aprenderás a: montar tu propio cluster, comandos de linux, instalar programas y configurarlos, como se dividen los procesos y resolver los problemas que te encuentres a medida de la instalación y configuración (seguro que aparecen :))

Enlaces que te pueden ser de interés:

http://www.mcs.anl.gov/research/projects/mpich2/

http://wiki.mcs.anl.gov/mpich2/index.php/Main_Page

http://www.mpi-forum.org/

http://www-meg.phys.cmu.edu/~bellis/Notes/IntroToMPItalk.pdf

17 comments

  1. Pingback: Móntate un cluster de ordenadores en casa -Linux-

  2. Pingback: first tests of cluster

    1. Antonio Post author

      Hola Carlos, me alegro de que este tutorial te haya servido de aprendizaje. Personalmente me siento muy bien al enseñar cosas que yo ya he aprendido, al igual que mis compañeros que me ayudaron a realizar este pequeño proyecto.

      Saludos.

  3. dada

    Men tengo problemas en el punto 6 me dice :

    unrecognized mount point home/clusterub1

    en el comando puse :
    sudo mount ubuntucluster:/home/clusterub1 /home/clusterub1

    en ambos servidores el usuario es clusterub1
    el servidor uno se llama ubuntucluster y el dos en donde meti el comando ubuntucluster2

    en el paso 5 en el ubuntucluster hice:
    puse comando sudo nano /etc/exports

    luego dentro del fichero agrege una nueva linea que dice : home/clusterub1 *(rw,sync)

    no se por que me sale el error ese de que no reconoce al montar. Hice ping entre ambos servidores y si llegan datos. Espero puedas ayudarme, muchos saludos

  4. Jorge

    Hola Antonio,

    En el punto 11 tengo un problema, al ejecutar mpdboot -n 2 -f .mpd.hosts me sale el error:

    mpdboot server1 (handle_mpd_output 420): from mpd on server2, invalid port info:
    no_port

    Porqué pasa esto?, favor tu ayuda.

    Gracias!

Deja un comentario